This project has moved and is read-only. For the latest updates, please go here.

Clipboard and quick unlock fail

Sep 29, 2013 at 9:44 PM
in version 0.8.6 I notice that clipboard pasting of user name and password fails, and the quick unlock feature doesn´t work anymore.
Firs I was not sure if it is an interdependency between Keepass2Android and another app (like ESET Antivirus, a task switcher etc.), but reverting to 0.8.5 solved the issue, i.e. with 0.8.5 it works fine, 0.8.6 seems to be broken.
LG Optimus 4X P880 with Android 4.0.3
Did you change anything in the implementation of this features ?

Sep 29, 2013 at 11:40 PM
I did some testing. With 0.8.5 I was able to copy the password to the clipboard, but the taskbar entries were not removed after expiration time, and the quick unlock didn´t work for me.
Now I installed 0.8.4, now it´s fine. Clipboard is working, the taskbar entries disappear after a minute, and Quick unlock works again.


P.S.: I forgot to thank you for the great software ! KeepassDroid is fine, but KP2A is much better.
Nov 26, 2013 at 10:10 AM
I have tried quick unlock on the latest regular and offline version of the software. It does not work on the initial login in either one but after the full password is entered to first unlock the database, only the last three characters are required to reopen the db until the app shuts down.
Nov 26, 2013 at 8:49 PM
@caliphman: thanks for the confirmation, that's the intended behavior. (Of course you need to enter the full password once, otherwise KP2A couldn't open the file at all.)

@kt1: The behavior that you describe sounds like the application gets killed by Android (in a way that it doesn't even get notified so it cannot remove the notifications). This is reported every now and then by a few users but I haven't really found a way to solve this.

Did you try with 0.9.x?
Nov 29, 2013 at 2:57 PM
Hi Philipp,

indeed - since 0.9 I was not able to reproduce the problem.
Maybe in the meantime I deinstalled an other app interfering with KP2A ...

Best regards
Dec 29, 2013 at 9:12 PM

I've tried to use 0.9.2-r2 on my SGS 4 and Galaxy Tab 10.1 2014. On both devices QuickUnlock does NOT work. Can you suggest a solution?

Dec 30, 2013 at 2:49 PM
what do you mean with "does not work"? Does it never work? If Keepass2Android is killed by Android, the QuickUnlock service is stopped as well.
Dec 30, 2013 at 4:37 PM
Well, when should it work? After a reboot it does not work. It asks for the QuickUnlock code but then for the password too. The notification icon is beeing displayed. When Keepass2Android closes the database after the timeout the icon is still displayed but the code does not work.
Dec 30, 2013 at 6:39 PM
first a little background: QuickUnlock means, you unlock the database with your full password once. Then the app is kept alive (as far as this is possible, see my answer above). As long as it's not killed by android (or the database is closed by the user), the database is kept in memory. To unlock it (after a certain amount of time or after locking the database manually), the QuickUnlock key is required.
By default, the key is the last 3 characters of your password (i.e. "ord" if your password is "mytestpassword").

This means: After reboot, you should see the normal password screen (for entering the full password). If you have your database opened (open lock symbol in notification bar) and click the "lock database" menu, you should see the QuickUnlock screen (and a closed lock symbol in the notification bar). Now leave the app and open it again (e.g. by using the Share URL menu from your browser) - and you should see QuickUnlock again. After entering the QuickUnlock key, the notification icon switches to the open lock again.

QuickUnlock doesn't work if you have a keyfile only.

Does that help?