4
Vote

HTTP WebDav issue unsupported auth scheme

description

Using plain http WebDav on my lan to my windows server. Worked fine until I got the 1.0.1 release, now reporting unsupported auth scheme when syncing.
Have closed and tried to reopen database but now won't open at all with this error.
Switched to beta program,installed 1.0.1-d as mentioned about https WebDav in other bug but still an issue.

comments

PhilippC wrote Jan 29 at 5:31 PM

which auth scheme does your server expect/support?

Doogstar wrote Jan 29 at 10:16 PM

It's using windows authentication with NTLM provider. It worked fine until this latest release.

It's my personal IIS so I can reconfigure it if needed if there's something obvious that you can suggest, but obviously other users may be in a similar position but not in control of the server they are using.

miknor0001 wrote Feb 2 at 5:40 AM

Having the same problem using windows authentication with NTLM provider. It worked fine until this latest release. 1.0.1-D

What to do?

PhilippC wrote Feb 4 at 6:10 PM

can you create an account for me for testing (credentials to crocoapps@gmail.com please)?

HedRat wrote Feb 9 at 12:52 PM

That's a 'me too' vote for connecting to a Sharepoint hosted .kdbx file.

Doogstar wrote Feb 9 at 7:51 PM

Unfortunately I can't easily create a testing account as it's inside my LAN, so would need VPN etc too, which I'd rather not do if I can avoid it.

Hopefully someone with a public facing server can setup some credentials to get this resolved.

I did try downloading the source to see if I could throw the error in the emulator, but it wouldn't compile due to the WebDav project not being in there.

TimoD wrote Feb 16 at 9:14 AM

I have the same problem with my SharePoint-Server making KeePass2Android unusable for me. Is there a possibility to get a quick fix? If you don't have an account yet, I can create one for you on my SharePoint.

sansom wrote Mar 1 at 5:18 PM

Hi, I have the same problem with nextcloud 11 and enabled Two Factor TOTP Provider plugin.

It looks like the app-password doesn't work and I receive "unsupported auth scheme" error message.

When I disabled the two factor plugin - it started working again - but I would like to use the plugin because of security.

bunzelj wrote Mar 2 at 11:30 PM

I had started another issue for this exact same thing not realizing this one existed. Regardless, I was able to get mine working. I have full control over my server (windows server 2012 iis) and after playing around it turned out after disabling windows authentication and instead using basic authentication. I'm not an expert but I came to trying this after doing some reading on NTLM. Like I said it works nkw, just trying to determine now if using basic is still secure.

depswa wrote May 31 at 4:24 PM

I have the same issue with WebDAV. Here is the information about the auth scheme I get when I access the site with Google Chrome:

The connection to this site is encrypted and authenticated using a strong protocol (TLS 1.2), a strong key exchange (ECDHE_RSA with P-256), and a strong cipher (AES_256_GCM).