This project has moved and is read-only. For the latest updates, please go here.

Problem with YubiKey Neo

Dec 18, 2013 at 11:58 PM
Hi Philipp,

I just updated keepass2droid and was excited about the new OTP feature. I am using my YubiKey Neo a lot of weeks with my Keepass DB and couldn't use K2D...

I tried to open the DB with the new OTP feature and got a problem.
My generated OTPs don't get pasted into the Textareas. When holding the Neo on my SGS3 (rooted & custom Rom from Temasek CM11/Kitkat 4.4.2).

I already deinstalled apps like NFC Tag writer and NFC Tag View... But nothing changed.

Any Idea?
Greets from Nuremberg
Dec 19, 2013 at 12:04 AM
Here is a Screenshot in my Dropbox

There seems to be no Copy-Function. I could only close the Popup...
Dec 19, 2013 at 4:22 AM
I don't know what app captures the NFC (in your screenshot), but you should see the possibility to use Keepass2Android here.
Please first make sure you configure NDEF on the Yubikey as described here:

If this doesn't help, we'll see what I can do.
Dec 19, 2013 at 10:30 AM
RTFM ;-)

It took a littlebit... but now it works! Some Time ago I programmed the Yubikey NDEF to "Text"...

You should write in the description that the NDEF payload HAS TO BE "". If the Textfield is empty it will not be programmed (no successful message appears at the top, but althoug no error-message).

My second mistake was in my first tests: I typed the url only with HTTP instead of https... so only the browser started ;-).

I have a suggestion for OTP-input: could you release an "tab" or simply jump to the next otp-field after every key?

With best regards and some nice holidays
Dec 19, 2013 at 7:00 PM
Glad to hear it's working now!
BTW on my Yubikey I tried to press "Reset" and "Program" (which makes the payload field empty) and after that the setup worked.

Regarding your suggestion: You don't need to move the cursor manually. The next OTP is entered into the next free OTP field!